Dell EMC bouche 3 failles critiques de ses systèmes Vmax

Un patch est venu boucher 6 failles dont 3 critiques sur les appliances Unisphere de Dell EMC.

Un patch est venu boucher 6 failles dont 3 critiques sur les appliances Unisphere de Dell EMC.

Plusieurs failles critiques repérées sur les appliances Unisphere for Vmax de Dell EMC pouvaient entraîner une compromission de l’intégralité du système informatique.

Dans un patch, Dell EMC vient de combler six failles dans l’interface de management de ses solutions de gestion de stockage VMAX. Trois d’entre-elles étaient considérées comme critiques, elles aurait pu être exploitées pour compromettre des données sensibles ou les système informatiques au complet. Elle concernaient toutes les appliances de gestion et de supervision Unisphere.

Une de ces failles critiques se trouvait au niveau de la librairie Granite DS. Cette dernière sert notamment de support serveur pour la gestion de la mémoire flash dans l’interface web des appliances. Des attaquant non authentifiés pouvaient ainsi l’utiliser pour accéder arbitrairement à des contenus avec les privilèges root.

vApp Manager touché par 4 failles

Les quatre autres failles se trouvaient au niveau de l’application vApp Manager d’Unisphere qui tourne sur le port 5480. La première, jugée critique permettait aux attaquant de passer par une entrée appelée GetSymmCmdCommand, pour exécuter des commandes arbitraire sans authentification, ont expliqué les chercheurs de Digital Defense dans leur rapport.

La seconde, elle aussi critique, concernait l’entrée RemoteServiceHandler. En l’exploitant, les attaquants pouvaient contourner les processus d’authentification d’autres entrées beaucoup plus sensibles. Avec cette faille, il était par exemple possible d’ajouter arbitrairement de nouveaux administrateur et donc de compromettre l’intégralité de l’appliance. Les trois autres failles étaient seulement jugées très sévères puisqu’elles nécessitaient une authentification pour être exploitée. Toutefois, elle permettait à des utilisateurs à bas privilèges d’exécuter des commandes en tant que root.

Go to Source


bouton-devis