WordPress va vous avertir sur les versions PHP obsolètes (avant de sévir)

Le système de gestion de contenu open-source (CMS – content management system) WordPress affichera des avertissements dans son panneau d’administration (à destination des administrateurs de site donc) si le site fonctionne sur une version PHP périmée.

 

Image : Felix Arntz, WordPress.org

Le but est de faire apparaitre les avertissements pour les sites utilisant une version PHP datée d’avant la branche 5.6.x (<=5.6). Les avertissements contiendront un lien vers une page d’assistance WordPress indiquant des informations sur la façon dont les propriétaires de sites peuvent mettre à jour la version PHP sous-jacente de leur serveur.

Dans les cas où les propriétaires de sites exécutent leurs portails WordPress sur des environnements d’hébergement Web étroitement contrôlés, l’hébergeur a la possibilité de modifier ce lien avec une URL personnalisée pointant vers son propre site de support. L’avertissement sera expédié et commencera à apparaitre avec WordPress 5.1, dont la sortie est prévue au début du printemps.

La décision de commencer à afficher cet avertissement a été prise en décembre 2018, après la sortie de la version WordPress 5.0. Les statistiques de mise à jour compilées quelques jours après la sortie de WP 5.0 ont révélé que 85 % des utilisateurs de WordPress 5.0 utilisaient des versions PHP 5.6 et ultérieures, donc seul un petit sous-ensemble de la communauté WordPress active verra de fait ces avertissements apparaitre sur leurs écrans.

Nous avons dit « communauté WordPress active » parce qu’il y a aussi des millions de sites qui utilisent les anciennes versions de WordPress, et beaucoup d’entre eux sont abandonnés ou tout simplement oubliés par leurs propriétaires.

Le plan à court terme est de migrer autant d’utilisateurs actifs que possible vers des versions plus récentes de PHP afin que l’équipe WordPress puisse abandonner complètement le support des anciennes versions de PHP.

L’équipe de WordPress aimerait modifier officiellement les exigences de la version PHP minimale de WordPress CMS en passant de PHP 5.2 – la version actuelle – à PHP 5.6 d’ici avril 2019. Une montée de version similaire est également prévue pour MySQL, avec MySQL 5.5 devenant la nouvelle exigence minimale.

Le plan à long terme est de faire de PHP 7.0 la version PHP minimale nécessaire pour faire fonctionner un site sous WordPress d’ici décembre 2019. L’annonce faite hier par l’équipe de WordPress est une surprise pour la communauté WordPress. La version minimale de PHP nécessaire à l’exécution d’un site WordPress n’a pas été modifiée depuis des années.

La raison pour laquelle l’équipe WordPress veut pousser les propriétaires de sites à mettre à jour leurs serveurs PHP sous-jacents est que l’équipe PHP a récemment abandonné le support des corrections de sécurité pour les branches PHP 5.6.x et PHP 7.0.x. Ces anciens serveurs PHP sont donc maintenant vulnérables aux attaques et à l’exploitation, comme plusieurs chercheurs en sécurité l’ont dit à ZDNet l’automne dernier.

Environ 66,7% de tous les sites Internet utilisent une version PHP non supportée, selon W3Techs. Et près d’un quart de tous les sites Internet fonctionnent sur un CMS WordPress. L’équipe de WordPress est le premier grand projet CMS à annoncer un plan concerté de migration des utilisateurs vers les versions PHP actuellement supportées.

« La publication de l’avis PHP augmentera de façon granulaire, dans le but de rattraper avec le temps la progression réelle de la version PHP » a déclaré Felix Arntz, un membre de l’équipe du CMS open-source WordPress.

Article « WordPress to show warnings on servers running outdated PHP versions » traduit et adapté par ZDNet.fr

Go to Source


bouton-devis